Holy Rollerz Christian Automotive Forums






Odd Problem....

ask away...

Odd Problem....

Postby AaronsRod on Sat Oct 13, 2007 5:50 pm

97 Caravan
3.0L
3 spd Auto
195,000 kms


Just picked this thing up last night as I am tired of fixing the Turbo Van all the time..Watch for it to be going up for sale soon...

Anyway...There's one annoying issue with this 97 that has me scratching my head...

Start up is sometimes right on..No problem...then other times it sounds like its either not getting spark or fuel.Sometimes in the middle of this "free-spinning" it catches and starts right up....Other times you stop cranking and then on the 2nd or third try,the cranking tone changes and it fires right away.This happens at various intervals.Very unpredictable.

As well(here's the big issue).Once the van is warmed up,it runs great.No knocks,rattles,no miss,quite as a mouse(You can barely hear it run).You can drive and drive and driave..Nothing...I drove it up and down my road this AM and it went like stink.NO hesitation...no misses...

EXCEPT......From time to time...again,very unpredictable...You can sit as though your at a red light...Foot on the brake,off the gas,its fine...take your foot off the brake,its fine...Go to give it gas,it will either die or at least stumble.Sometimes it will recover,but not always.Sometimes you can "pull away from the light" no problem.No ryhme or reason to it.

Most of the time when you "feather"the gas from the "light" it will go fine,but not always.

I know that the computer was changed out.No change
It had a new battery and cables installed.No change.
I changed the Coolant temp.Sensor this AM.No change.
I changed the fuel filter.No change.
Checked the air filter,cap,rotor,wires.All look to be fairly new and in very good order.


My possible theories:
Goofy Cranksensor
slightly streched timing belt,throwing the timing out that tiny bit to cause the issue.
A weakening fuel pressure regulator.I need to find a fuel pressure gauge for this one.

Those are the top 3 things I'm thinking,but would be open to hear any other possible theories.

Thanks in advance for any help anyone can be.



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby ST3ALTHPSYCH0 on Sat Oct 13, 2007 6:17 pm

My first guess would be the FPR. Do you have a Haynes for it? They have a pretty comprehensive troubleshooting section.



It's not how you drive your car... oh, wait, it IS?!?
Image


(\_/)IN MEMORY OF JOHNY - May he rest in
(o.O)peace
(> <) <---This is Bunny, Copy Bunny into your signature to help him on his way to world domination.

Click and read posts 1&3 to help newly wed computer geeks!
User avatar
ST3ALTHPSYCH0
I post more than I sleep
I post more than I sleep
 
Posts: 389
Joined: Sun Sep 17, 2006 3:00 am
Location: Chattanooga, TN
Gender: None specified
Rank: HRC3 Member

Postby AaronsRod on Sat Oct 13, 2007 7:36 pm

I just talked to my Pastor...long story how he got involved in this...lol...and got some more low down on the van..

He had into a shop and had the Idle Air Control(IAC)replaced as well as a couple other sensors.He's going to try and find the invoice for it and get it to me.He said it also had an injector flush done at the same time.And none of this solved it.

I should also make note that I ran it for codes and came up with nothing.

I'm going to leave it for a day or so...mull it over...talk to some people..get some more background on whats been done and go from there...

Its going to be something stupid...I just know it....



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby AaronsRod on Sat Oct 13, 2007 7:37 pm

BTW...I too also lean towards the FPR....but I can't even see the thing on this motor,so I need to get some info before I go ripping things apart...

I'll let you know...



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby integra evan on Sat Oct 13, 2007 7:45 pm

Sounds like you're losing fuel pressure somewhere...has the fuel pump ever been changed? You'll have to do a fuel pressure test, see what it reads, and see where it's suppose to read. If it's low, it's likely a faulty pump.



Image
User avatar
integra evan
Teggin' it up holy style
 
Posts: 14005
Joined: Wed Apr 14, 2004 6:33 pm
Gender: Male
Vehicle: 1995 Acura Integra SE
Rank: HRC3 Member

Postby AaronsRod on Mon Oct 15, 2007 12:24 am

Ok...In between services today I ran to the junkyard and grabbed a fuelpump with FPR and a MAP sensor.Tonight I put the stuff in....

Problem still remains!!!!ARGGGGGHHHHHHHH!!!

But,on a positve note,the hard start is pretty much gone.It seems so far to start very regular now.Same amount of cranking needed each time.Which makes me wonder if its not a combo of problems.

When time allows,I make another run and grab a TPS and a Cranksensor...

If that don't work,its time to sit down with a stack of diagrams for the fuel system,evap emissions controls and the ignition system and start weeding through the options.


Man,what a pain in the butt this thing is turning into!!



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby AaronsRod on Mon Oct 15, 2007 8:57 pm

Ok...Tonight I changed the PCV and the ignition coil,as well as cleaned the throttle plate...all on the advice of various mechanics I know...

Stalling still remains!!

This si just getting stupid!!



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby AaronsRod on Thu Oct 18, 2007 12:55 am

Its not the TPS...

I'm running out of ideas....



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby AaronsRod on Sat Oct 20, 2007 9:47 am

Ok...MAJOR tun of events here!!

Last night,a buddy loaned me use of hjis Snap-On Solace scanner and his lab scope...GREAT!!

MY roomie went and picked it up from his shop,then when I got home,I hooked it up and ran some tests.Everything for the most part looked ok.

So,we hit the road to head out to this buddies place for him to have a look and to give him back his gear.I noticed the van didn't have much top end power while on the Hwy.

Then it got interesting...........................

It started raining on the way.Other than the wipers not working right,everything seemed to be going ok...til we stopped in a small town on the way for supper....Maybe 5-10 mins from my house.

We stopped and ate,got back in the van and had a REALLY bad time getting it started.But it did and we drove over to the gas station in the same parking lot.It stalled at least twice in that little distance.It was getting worse.

So I put 10Litres of premium in,went in and paid.Came out to find a dude in a truck sitting witing for the pump right almost on my bumper.SO I get in...and crank....and crank....and crank...and crank....and crank some more.....after about5 or so tries,it finally started.....than died....then started and died....Finally it started and ran enough for me to drive it across the parking lot to let it warm back up.

We got back on the road,drove for about 10-15 mins to get to Earl's place.No problems with stalling or hesitation or anything that distance.

When Earl comes out,he walks around the back and right away says it doesnt smell right.HE then gets in to see whats it doing for himself.He did some playing with the throttle and what not and at one point put a foot on the brake and one on the gas full out.The thing pinged,and misfired and rattled and made the most awful noises....


IGNITION!!

After that,we could barely keep the van running at all...in park or otherwise!!

We it took about 6 startups to get it from his parking pad to his garage..about 150 ft at most....

Something we both noticed on the scanner after we got there as well,is that the ignition timing was all over the place....from 11 to 23 degrees advance.This was before his little test.

Once we had it in the garage,he went in and played with some stuff,but we failed to find the culprut.We did find the timing belt is in need of changing.but Earl tends to think this is an electronic issue.

I wound up leaving the van at his place last night and getting ride with my roomie(THanks for bringing your car Travis as a backup/breakdown vehicle)

It may sound stupid,but tis a releif just knowing what area to look in.Before this,it sounded for sure like it was fuel/air related...I was starting to stress out about the whole deal...I slept better last night than I have in a week....

So now I get a bunch of info together and try to find some answers.

Please pray about this....Right now I have 2 vans...one that doesnt shift right and not sure how long the trans will hold out and one that won't stay running......and winter is knocking at our door.....time is ticking...

I'll kepp ya posted....



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby ST3ALTHPSYCH0 on Sun Oct 21, 2007 9:11 pm

Hey, not to change the subject, but I see the thanks to Trav. Is he frequenting the site? If so, hey, glad you're here.

Is the turbo the one that doesn't shift? You should do a manual swap!!!



It's not how you drive your car... oh, wait, it IS?!?
Image


(\_/)IN MEMORY OF JOHNY - May he rest in
(o.O)peace
(> <) <---This is Bunny, Copy Bunny into your signature to help him on his way to world domination.

Click and read posts 1&3 to help newly wed computer geeks!
User avatar
ST3ALTHPSYCH0
I post more than I sleep
I post more than I sleep
 
Posts: 389
Joined: Sun Sep 17, 2006 3:00 am
Location: Chattanooga, TN
Gender: None specified
Rank: HRC3 Member

Postby AaronsRod on Tue Oct 23, 2007 12:54 am

I think Travis peeks in here every so often,but I don't think he's joined the board or anything yet...

Yes,the trubo van is the one that doesn't want to downshift sometimes...As far as the manual swap,that very thought ran thru my mind to day...That van could be avery cheap project for me.....I've got an 89 Sundance here with the 5 spd in it that I sold a buddy about 4 mths ago and he hasnt taken it from the property yet...I could very easily buy it back from him for the $150 I sold it to him for.....I also have a 91 Grand Caravan with 15" Wheels,which would mean a free brake upgrade....The basis is there...its just weather I want to go thru with it or not is the ??????


Now...about the 97 Caravan.....I went out Saturday to see what it would do after sitting all night and morning at my buddy's place....It ran like a top!!Its still had the stalling problem,but otherwise ran just as it had before.So I drove it home with only 2 stalls.

Tonight after talking to another mechanic buddy of mine,he ran some ideas past me.One included dowsing the dist. with cold water when it got hot and started stalling.So I tried this.When I got water on the dist.,it started acting just as it had after going thru the rain.SO I dug in deeper and found the O-Ring under the cap had been smooshed down into its little groove.I picked it out,rolled it around to get its shape back,set it back in place,and put the cap back on.Started it up,started by splashing water mostly on the wires and the tried snapping the throttle.I eventually POURED water all over the Distributor...about 1/2 litre I would guess....other than the hesitation(which would cause the stall while in drive)it ran fine...There's one problem solved....I hope....

I changed the crank sensor tonight and no change....


The friend I spoke with tonight rambled off a list of things I should start with....and unfortunatly,most of them,I really feel he's way off...I could very well be wrong in my thinking though....But some of them have really validity to them and sound possible....so I'll go back at it tommorow night and continue the hunt.....



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby HOLYRIDER on Wed Oct 24, 2007 3:57 pm

did you say that the wipers were not working have you checked the body control module bcm should be on the fuse block either under the hood or under the dash i believe is under the dash they go out all the time on the chryslers. just a thought



Image
User avatar
HOLYRIDER
Cristo Rican
 
Posts: 646
Joined: Mon Nov 27, 2006 4:00 am
Location: WINTER HAVEN,FL
Gender: Male
Vehicle: 91 Accord cb9
Rank: HRC3 Member



Postby dgonzales77 on Fri Oct 26, 2007 6:21 pm

So are you saying it runs fine when the weather is good and it acts up when the weather is cold?



Jhn 14:15 "If you love me, you will obey what I command.

Image
dgonzales77
Crazy Posting Machine
Crazy Posting Machine
 
Posts: 515
Joined: Tue Nov 21, 2006 4:00 am
Location: Poway CA.
Gender: None specified
Rank: HRC3 Member

Postby AaronsRod on Sat Oct 27, 2007 1:52 pm

Hey Guys...PROBLEM SOLVED!!

It was the pickup in the distributor!!

The long and short of it all was this....The oring under the cap had smooshed itself down in the groove it sits in,thus allowing water and whatnot into the distributor,in turn wrecking the pickup...

After 6 mths....about 3-4 shops.....countless man hours.....about $2000-$3000 in work...it took a $20 junkyard part and about 15 mins of work...problem is solved...

Now I'm trying to get the wipers working...while tinkering with the wiring,I lost the trun signals....lol....so for now I'm going to get the signals working again,slap it back together and deal with the wipers another time.....I still have wipers,but only when you hit the washer button......I agree with the idea that its the module under the dash.....Might make another run to the boneyard today or tommorow and grab one.....

Either way,I should,in theroy,have the ven on the road by Monday morning for work.....But we will see what the Lord has in mind....

Thanks for all the advise,people......



AaronsRod

..........You've made yourself your God and now God will make you a vessel of wrath.
Wipe the tears from our eyes,
Erase the fear from your heart
Put your knee in the dirt and bow to the God that holds your blood red
destiny in the palm of his awesome hands.
It's your choice-Bow by Focused
AaronsRod
Postmaster
Postmaster
 
Posts: 288
Joined: Sat Jun 02, 2007 3:00 am
Location: Calgary,Alberta,Canada
Gender: None specified
Rank: HRC3 User

Postby skiendog on Sun Oct 28, 2007 12:34 pm

yay!! i pray that it will be ready by monday morning!



HRC³ Forum Moderator
Welcome Wagon Member
NFATCA The ONLY organization fighting to protect what no other organization will touch.
User avatar
skiendog
!DAYN-JUH!
 
Posts: 15938
Joined: Sun Feb 27, 2005 4:47 pm
Location: beach
Gender: Male
Vehicle: E320
Rank: HRC3 Member

Next

Return to General Questions


Who is online

Users browsing this forum: No registered users and 5 guests

cron